Unintended breaking change in Actor run API endpoint

Incident Report for Apify

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 21:21 CET

Update

The Actor run endpoint issue has been resolved. The `stats` attribute is now returned correctly, and Actor runs should be fully operational.
Posted Oct 29, 2025 - 21:06 CET

Identified

The Actor run endpoint stopped returning `stats` attribute, which is a breaking change, especially for pay-per-event Actors using Python SDK. We've identified the issue and are working on a fix.
Posted Oct 29, 2025 - 20:06 CET
This incident affected: API (api.apify.com).