Issue with apify/send-mail Actor

Incident Report for Apify

Resolved

The latest version of the apify/send-mail Actor failed to email all recipients. The issue lasted from around 13:50 to 14:05 CEST. The root cause was identified, and the service of the Actor was restored.

We apologize for any inconvenience this might have caused. We take this problem seriously and will take steps to prevent such issues from occurring in the future.
Posted Sep 15, 2025 - 14:38 CEST